import Foundation
let pattern = #"value='[A-Za-z]+\,[0-9]+\,([A-Za-z0-9]+)\,([A-Za-z0-9]+)'>[A-Za-z0-9]+\s-\s(.*)?\s\("#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<option value='C,201301,F110,JEWL1050'>JEWL1050 - Industry Skills I (F110)</option>
<option value='C,201301,F114,JEWL1050'>JEWL1050 - Industry Skills I (F114)</option>
<option value='C,201301,F114,JEWL1054'>JEWL1054 - Jewellery Rendering & Illustra (F114)</option>
<option value='C,201301,F110,JEWL2029'>JEWL2029 - Production Techniques B (F110)</option>
<option value='C,201301,F114,JEWL2029'>JEWL2029 - Production Techniques B (F114)</option>
<option value='C,201301,LIAD,LANG9066'>LANG9066 - Italian For Beginners (LIAD)</option>
<option value='C,201301,T302,LAW1151'>LAW1151 - Canandian & Environmental Law (T302)</option>
<option value='C,201301,T305,LAW1151'>LAW1151 - Canandian & Environmental Law (T305)</option>
<option value='C,201301,F402,LAW1152'>LAW1152 - International Law & Agreements (F402)</option>
<option value='C,201301,T302,LAW3201'>LAW3201 - Protection Legislation (T302)</option>
<option value='C,201301,T303,LAW3201'>LAW3201 - Protection Legislation (T303)</option>
<option value='C,201301,T304,LAW3201'>LAW3201 - Protection Legislation (T304)</option>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)