use strict;
my $str = '<option value=\'C,201301,F110,JEWL1050\'>JEWL1050 - Industry Skills I (F110)</option>
<option value=\'C,201301,F114,JEWL1050\'>JEWL1050 - Industry Skills I (F114)</option>
<option value=\'C,201301,F114,JEWL1054\'>JEWL1054 - Jewellery Rendering & Illustra (F114)</option>
<option value=\'C,201301,F110,JEWL2029\'>JEWL2029 - Production Techniques B (F110)</option>
<option value=\'C,201301,F114,JEWL2029\'>JEWL2029 - Production Techniques B (F114)</option>
<option value=\'C,201301,LIAD,LANG9066\'>LANG9066 - Italian For Beginners (LIAD)</option>
<option value=\'C,201301,T302,LAW1151\'>LAW1151 - Canandian & Environmental Law (T302)</option>
<option value=\'C,201301,T305,LAW1151\'>LAW1151 - Canandian & Environmental Law (T305)</option>
<option value=\'C,201301,F402,LAW1152\'>LAW1152 - International Law & Agreements (F402)</option>
<option value=\'C,201301,T302,LAW3201\'>LAW3201 - Protection Legislation (T302)</option>
<option value=\'C,201301,T303,LAW3201\'>LAW3201 - Protection Legislation (T303)</option>
<option value=\'C,201301,T304,LAW3201\'>LAW3201 - Protection Legislation (T304)</option>';
my $regex = qr/value='[A-Za-z]+\,[0-9]+\,([A-Za-z0-9]+)\,([A-Za-z0-9]+)'>[A-Za-z0-9]+\s-\s(.*)?\s\(/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}