using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"v[12]-([1-9]+?-[0-9]+?-[0-9]+?)-";
string input = @"account-device-v2-2-3-63-21900
account-device-v1-2-3-63-21900
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}