// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"v[12]-([1-9]+?-[0-9]+?-[0-9]+?)-").unwrap();
let string = "account-device-v2-2-3-63-21900
account-device-v1-2-3-63-21900
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}