re = /v[12]-([1-9]+?-[0-9]+?-[0-9]+?)-/
str = 'account-device-v2-2-3-63-21900
account-device-v1-2-3-63-21900
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end