const regex = new RegExp('v[12]-([1-9]+?-[0-9]+?-[0-9]+?)-', 'g')
const str = `account-device-v2-2-3-63-21900
account-device-v1-2-3-63-21900
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}