package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`v[12]-([1-9]+?-[0-9]+?-[0-9]+?)-`)
var str = `account-device-v2-2-3-63-21900
account-device-v1-2-3-63-21900
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}