using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z][a-zA-Z0-9_]*$";
string input = @"de.com
1.2.3.4
.3.4.5
den.com
.com
ny com
1.200.5
hostname
.nothost
-nothostagain
host-
0.0.0.
0.0.2.3
1.100.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}