import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z][a-zA-Z0-9_]*$";
final String string = "de.com\n"
+ "1.2.3.4\n"
+ ".3.4.5\n"
+ "den.com\n"
+ ".com\n"
+ "ny com\n"
+ "1.200.5\n"
+ "hostname\n"
+ ".nothost\n"
+ "-nothostagain\n"
+ "host-\n"
+ "0.0.0.\n"
+ "0.0.2.3\n"
+ "1.100.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}