$re = '/^[a-zA-Z][a-zA-Z0-9_]*$/m';
$str = 'de.com
1.2.3.4
.3.4.5
den.com
.com
ny com
1.200.5
hostname
.nothost
-nothostagain
host-
0.0.0.
0.0.2.3
1.100.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);