# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-zA-Z][a-zA-Z0-9_]*$"
test_str = ("de.com\n"
"1.2.3.4\n"
".3.4.5\n"
"den.com\n"
".com\n"
"ny com\n"
"1.200.5\n"
"hostname\n"
".nothost\n"
"-nothostagain\n"
"host-\n"
"0.0.0.\n"
"0.0.2.3\n"
"1.100.\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.