package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z][a-zA-Z0-9_]*$`)
var str = `de.com
1.2.3.4
.3.4.5
den.com
.com
ny com
1.200.5
hostname
.nothost
-nothostagain
host-
0.0.0.
0.0.2.3
1.100.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}