using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\d(][\s\d()-]{5,14})(?:[\s;,.]|$)";
string input = @"(123) 35 222 1233222, 123-32-22 1233232222 21233222,21233222 123-332-322";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}