$re = '/([\d(][\s\d()-]{5,14})(?:[\s;,.]|$)/';
$str = '(123) 35 222 1233222, 123-32-22 1233232222 21233222,21233222 123-332-322';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);