re = /([\d(][\s\d()-]{5,14})(?:[\s;,.]|$)/
str = '(123) 35 222 1233222, 123-32-22 1233232222 21233222,21233222 123-332-322'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end