import re
regex = re.compile(r"([\d(][\s\d()-]{5,14})(?:[\s;,.]|$)")
test_str = "(123) 35 222 1233222, 123-32-22 1233232222 21233222,21233222 123-332-322"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")