// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\d(][\s\d()-]{5,14})(?:[\s;,.]|$)").unwrap();
let string = "(123) 35 222 1233222, 123-32-22 1233232222 21233222,21233222 123-332-322";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}