using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"microsoft_?[0-9]+_?[a-z]+\.(zip|exe|xls|xlsm)";
string input = @"MICROSOFT_0383760007_contact.exe
MICROSOFT0383760007_contacto.zip
MICROSOFT_0383760007contacto.zip
MICROSOFT0383760007contacto.zip
^[Mm][Ii][Cc][Rr][Oo][Ss][Oo][Ff][Tt][_][0-9]+[_][a-z]+.zip$
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}