re = /microsoft_?[0-9]+_?[a-z]+\.(zip|exe|xls|xlsm)/i
str = 'MICROSOFT_0383760007_contact.exe
MICROSOFT0383760007_contacto.zip
MICROSOFT_0383760007contacto.zip
MICROSOFT0383760007contacto.zip
^[Mm][Ii][Cc][Rr][Oo][Ss][Oo][Ff][Tt][_][0-9]+[_][a-z]+.zip$
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end