use strict;
my $str = 'MICROSOFT_0383760007_contact.exe
MICROSOFT0383760007_contacto.zip
MICROSOFT_0383760007contacto.zip
MICROSOFT0383760007contacto.zip
^[Mm][Ii][Cc][Rr][Oo][Ss][Oo][Ff][Tt][_][0-9]+[_][a-z]+.zip$
';
my $regex = qr/microsoft_?[0-9]+_?[a-z]+\.(zip|exe|xls|xlsm)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}