import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "microsoft_?[0-9]+_?[a-z]+\\.(zip|exe|xls|xlsm)";
final String string = "MICROSOFT_0383760007_contact.exe\n\n\n"
+ "MICROSOFT0383760007_contacto.zip\n"
+ "MICROSOFT_0383760007contacto.zip\n"
+ "MICROSOFT0383760007contacto.zip\n\n\n"
+ "^[Mm][Ii][Cc][Rr][Oo][Ss][Oo][Ff][Tt][_][0-9]+[_][a-z]+.zip$\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}