const regex = /microsoft_?[0-9]+_?[a-z]+\.(zip|exe|xls|xlsm)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('microsoft_?[0-9]+_?[a-z]+\\.(zip|exe|xls|xlsm)', 'ig')
const str = `MICROSOFT_0383760007_contact.exe
MICROSOFT0383760007_contacto.zip
MICROSOFT_0383760007contacto.zip
MICROSOFT0383760007contacto.zip
^[Mm][Ii][Cc][Rr][Oo][Ss][Oo][Ff][Tt][_][0-9]+[_][a-z]+.zip\$
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}