use strict;
my $str = '08001301001
08002401002 / 08002601003 / 17134604034
08004701005 / 08005101001';
my $regex = qr/\b(\d{5})\d/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";