# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(a)?b(?(1)c|d)/\1/gm;t' <<< "matches bd and abc. It does not match bc, but does match bd in abd. Let's see how this regular expression works on each of these four subject strings.
If-Then-Else Conditionals in Regular Expressions
http://www.regular-expressions.info/conditional.html"