#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(a)?b(?(1)c|d)"
Local $sString = "matches bd and abc. It does not match bc, but does match bd in abd. Let's see how this regular expression works on each of these four subject strings." & @CRLF & _
"If-Then-Else Conditionals in Regular Expressions" & @CRLF & _
"http://www.regular-expressions.info/conditional.html"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)