re = /(a)?b(?(1)c|d)/m
str = 'matches bd and abc. It does not match bc, but does match bd in abd. Let\'s see how this regular expression works on each of these four subject strings.
If-Then-Else Conditionals in Regular Expressions
http://www.regular-expressions.info/conditional.html'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result