use strict;
my $str = 'matches bd and abc. It does not match bc, but does match bd in abd. Let\'s see how this regular expression works on each of these four subject strings.
If-Then-Else Conditionals in Regular Expressions
http://www.regular-expressions.info/conditional.html';
my $regex = qr/(a)?b(?(1)c|d)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";