const regex = /(a)?b(?(1)c|d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(a)?b(?(1)c|d)', 'gm')
const str = `matches bd and abc. It does not match bc, but does match bd in abd. Let's see how this regular expression works on each of these four subject strings.
If-Then-Else Conditionals in Regular Expressions
http://www.regular-expressions.info/conditional.html`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);