using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^>]*>\s*<\/[^>]*>";
string substitution = @"";
string input = @"<p></p><div> to make links</div><b> </b>
<a href=""http://foo.com""></a><p> for linebreak add 2 spaces at end
</p><strong></strong><i></i>";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}