re = /<[^>]*>\s*<\/[^>]*>/
str = '<p></p><div> to make links</div><b> </b>
<a href="http://foo.com"></a><p> for linebreak add 2 spaces at end
</p><strong></strong><i></i>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result