import re
regex = re.compile(r"<[^>]*>\s*<\/[^>]*>", flags=re.DOTALL)
test_str = ("<p></p><div> to make links</div><b> </b>\n"
"<a href=\"http://foo.com\"></a><p> for linebreak add 2 spaces at end\n"
"</p><strong></strong><i></i>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)