// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<[^>]*>\s*<\/[^>]*>").unwrap();
let string = "<p></p><div> to make links</div><b> </b>
<a href=\"http://foo.com\"></a><p> for linebreak add 2 spaces at end
</p><strong></strong><i></i>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}