const regex = /<[^>]*>\s*<\/[^>]*>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^>]*>\\s*<\\\/[^>]*>', 'gs')
const str = `<p></p><div> to make links</div><b> </b>
<a href="http://foo.com"></a><p> for linebreak add 2 spaces at end
</p><strong></strong><i></i>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);