#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+://\w+\.\w+\.\w+[^"]+"
Local $sString = "http://net.tutsplus.com/tutorials/other/8-regular-expressions-you-should-know/"" & @CRLF & _
" http://www.asecuritysite.com/content/icon_clown.gif" alt="if broken see alex@school.ac.uk +44(0)1314552759" height="100"" & @CRLF & _
" http://www.rottentomatoes.com/m/sleeper/"" & @CRLF & _
" http://www.rottentomatoes.com/m/sleeper/trailer/"" & @CRLF & _
" http://www.rottentomatoes.com/m/star_wars/"" & @CRLF & _
" http://www.rottentomatoes.com/m/star_wars/trailer/"" & @CRLF & _
" http://www.rottentomatoes.com/m/wargames/"" & @CRLF & _
" http://www.rottentomatoes.com/m/wargames/trailer/"" & @CRLF & _
" https://www.sans.org/press/sans-institute-and-crowdstrike-partner-to-offer-hacking-exposed-live-webinar-series.php"> SANS to Offer "Hacking Exposed Live"" & @CRLF & _
" https://www.sans.org/webcasts/archive/2013""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")