import re
regex = re.compile(r"\w+://\w+\.\w+\.\w+[^\"]+", flags=re.MULTILINE)
test_str = ("http://net.tutsplus.com/tutorials/other/8-regular-expressions-you-should-know/\"\n"
" http://www.asecuritysite.com/content/icon_clown.gif\" alt=\"if broken see alex@school.ac.uk +44(0)1314552759\" height=\"100\"\n"
" http://www.rottentomatoes.com/m/sleeper/\"\n"
" http://www.rottentomatoes.com/m/sleeper/trailer/\"\n"
" http://www.rottentomatoes.com/m/star_wars/\"\n"
" http://www.rottentomatoes.com/m/star_wars/trailer/\"\n"
" http://www.rottentomatoes.com/m/wargames/\"\n"
" http://www.rottentomatoes.com/m/wargames/trailer/\"\n"
" https://www.sans.org/press/sans-institute-and-crowdstrike-partner-to-offer-hacking-exposed-live-webinar-series.php\"> SANS to Offer \"Hacking Exposed Live\"\n"
" https://www.sans.org/webcasts/archive/2013\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")