import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+://\\w+\\.\\w+\\.\\w+[^\"]+";
final String string = "http://net.tutsplus.com/tutorials/other/8-regular-expressions-you-should-know/\"\n"
+ " http://www.asecuritysite.com/content/icon_clown.gif\" alt=\"if broken see alex@school.ac.uk +44(0)1314552759\" height=\"100\"\n"
+ " http://www.rottentomatoes.com/m/sleeper/\"\n"
+ " http://www.rottentomatoes.com/m/sleeper/trailer/\"\n"
+ " http://www.rottentomatoes.com/m/star_wars/\"\n"
+ " http://www.rottentomatoes.com/m/star_wars/trailer/\"\n"
+ " http://www.rottentomatoes.com/m/wargames/\"\n"
+ " http://www.rottentomatoes.com/m/wargames/trailer/\"\n"
+ " https://www.sans.org/press/sans-institute-and-crowdstrike-partner-to-offer-hacking-exposed-live-webinar-series.php\"> SANS to Offer \"Hacking Exposed Live\"\n"
+ " https://www.sans.org/webcasts/archive/2013\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}