import Foundation
let pattern = #"\w+://\w+\.\w+\.\w+[^"]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://net.tutsplus.com/tutorials/other/8-regular-expressions-you-should-know/"
http://www.asecuritysite.com/content/icon_clown.gif" alt="if broken see alex@school.ac.uk +44(0)1314552759" height="100"
http://www.rottentomatoes.com/m/sleeper/"
http://www.rottentomatoes.com/m/sleeper/trailer/"
http://www.rottentomatoes.com/m/star_wars/"
http://www.rottentomatoes.com/m/star_wars/trailer/"
http://www.rottentomatoes.com/m/wargames/"
http://www.rottentomatoes.com/m/wargames/trailer/"
https://www.sans.org/press/sans-institute-and-crowdstrike-partner-to-offer-hacking-exposed-live-webinar-series.php"> SANS to Offer "Hacking Exposed Live"
https://www.sans.org/webcasts/archive/2013"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)