using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+://\w+\.\w+\.\w+[^""]+";
string input = @"http://net.tutsplus.com/tutorials/other/8-regular-expressions-you-should-know/""
http://www.asecuritysite.com/content/icon_clown.gif"" alt=""if broken see alex@school.ac.uk +44(0)1314552759"" height=""100""
http://www.rottentomatoes.com/m/sleeper/""
http://www.rottentomatoes.com/m/sleeper/trailer/""
http://www.rottentomatoes.com/m/star_wars/""
http://www.rottentomatoes.com/m/star_wars/trailer/""
http://www.rottentomatoes.com/m/wargames/""
http://www.rottentomatoes.com/m/wargames/trailer/""
https://www.sans.org/press/sans-institute-and-crowdstrike-partner-to-offer-hacking-exposed-live-webinar-series.php""> SANS to Offer ""Hacking Exposed Live""
https://www.sans.org/webcasts/archive/2013""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}