using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\S+(?: \S+)*$";
string input = @"Imaref
1233454AS
ReferencesCanContainSpaces
References Can Contain Spaces
References Can Contain Spaces but not at the end or beginning
References Can Contain Spaces but not at the end
References Can Contain Spaces but not at the beginning
FOLLOWINGSPACE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}