// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\S+(?: \S+)*$").unwrap();
let string = "Imaref
1233454AS
ReferencesCanContainSpaces
References Can Contain Spaces
References Can Contain Spaces but not at the end or beginning
References Can Contain Spaces but not at the end
References Can Contain Spaces but not at the beginning
FOLLOWINGSPACE";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}