re = /^\S+(?: \S+)*$/m
str = 'Imaref
1233454AS
ReferencesCanContainSpaces
References Can Contain Spaces
References Can Contain Spaces but not at the end or beginning
References Can Contain Spaces but not at the end
References Can Contain Spaces but not at the beginning
FOLLOWINGSPACE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end