import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\S+(?: \\S+)*$";
final String string = "Imaref\n"
+ "1233454AS\n"
+ "ReferencesCanContainSpaces\n"
+ "References Can Contain Spaces\n"
+ "References Can Contain Spaces but not at the end or beginning\n"
+ "References Can Contain Spaces but not at the end \n"
+ " References Can Contain Spaces but not at the beginning\n"
+ "FOLLOWINGSPACE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}