const regex = new RegExp('^\\S+(?: \\S+)*$', 'gm')
const str = `Imaref
1233454AS
ReferencesCanContainSpaces
References Can Contain Spaces
References Can Contain Spaces but not at the end or beginning
References Can Contain Spaces but not at the end
References Can Contain Spaces but not at the beginning
FOLLOWINGSPACE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}