#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:([0-9]+) X,)?(?: )?(?:([0-9]+) Y,)?(?: Z)?$"
Local $sString = "66 X, 55 Y, Z" & @CRLF & _
"66 X, 55 Y," & @CRLF & _
"66 X, Z" & @CRLF & _
"55 Y, Z" & @CRLF & _
"66 X," & @CRLF & _
"55 Y,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")