import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:([0-9]+) X,)?(?: )?(?:([0-9]+) Y,)?(?: Z)?$";
final String string = "66 X, 55 Y, Z\n"
+ "66 X, 55 Y,\n"
+ "66 X, Z\n"
+ "55 Y, Z\n"
+ "66 X,\n"
+ "55 Y,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}