re = /^(?:([0-9]+) X,)?(?: )?(?:([0-9]+) Y,)?(?: Z)?$/m
str = '66 X, 55 Y, Z
66 X, 55 Y,
66 X, Z
55 Y, Z
66 X,
55 Y,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end