$re = '/^(?:([0-9]+) X,)?(?: )?(?:([0-9]+) Y,)?(?: Z)?$/m';
$str = '66 X, 55 Y, Z
66 X, 55 Y,
66 X, Z
55 Y, Z
66 X,
55 Y,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);