#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)http:\/\/example\.com\/\w+\/?$"
Local $sString = "http://example.com/something" & @CRLF & _
"http://example.com/foo" & @CRLF & _
"http://example.com/foo/" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://example.com" & @CRLF & _
"http://example.com/" & @CRLF & _
"http://example.com/something/else" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")