re = /http:\/\/example\.com\/\w+\/?$/m
str = 'http://example.com/something
http://example.com/foo
http://example.com/foo/
http://example.com
http://example.com/
http://example.com/something/else
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end