$re = '/http:\/\/example\.com\/\w+\/?$/m';
$str = 'http://example.com/something
http://example.com/foo
http://example.com/foo/
http://example.com
http://example.com/
http://example.com/something/else
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);